Le wiki de WIMS EDU

L'association WIMS EDU a ouvert ce wiki afin de favoriser les collaborations entre utilisateurs de WIMS.

Outils pour utilisateurs

Outils du site


installation:logiciels_particuliers

GAP non reconnu par WIMS

Il peut y avoir plusieurs cas pour lesquels la communication entre WIMS et le logiciel GAP peut dysfonctionner. Selon votre cas, l'une et/ou l'autre des solutions ci-dessous devrait vous aider :

Bug spécifique à Debian

Commencez par retirer le “.sh” dans la ligne de commande de GAP configurée dans WIMS (interface administrateur → Logiciels périphériques)

Gap non reconnu (wims < 4.09d)

Si GAP n'est pas reconnu par WIMS, vous pouvez essayer ce qui suit (avant la version 4.09d de wims).

  • Faire l'installation de GAP
  • modifier le fichier gap.sh que l'on trouve par exemple dans gap4r5/bin/gap.sh

en ajoutant dans l'avant-dernier bloc export HOME=/nodir

  • vérifier que la commande permettant l'exécution de GAP est correcte

(interface administrateur → Logiciels périphériques)

Pour accélérer l'utilisation de GAP

Il arrive parfois que GAP met tellement de temps à répondre que WIMS considère qu'il est absent. Suivez cette démarche pour corriger cela :

  • Lancer dans le répertoire $(wims) la commande
echo 'SaveWorkspace("workspace");' | $adresse_gap.sh -q -r -R >/dev/null
  • Changer la commande d'exécution de GAP en rajoutant -L $(wims)/workspace
Vous pourriez laisser un commentaire si vous étiez connecté.
installation/logiciels_particuliers.txt · Dernière modification: 10/07/2015 09:34 par obado