Le wiki de WIMS EDU

L'association WIMS EDU a ouvert ce wiki afin de favoriser les collaborations entre utilisateurs de WIMS.

Outils pour utilisateurs

Outils du site


installation:ubuntu

Ubuntu 16.04

17 mai 2016 : [OB] Installation fonctionnelle sur Kubuntu 16.04 LTS attention toutefois : par défaut, le module “CGI” n'est pas activé dans Apache. il vous faudra donc taper la commande suivante dans le terminal :

sudo apt-get install libapache2-mod-fastcgi
sudo a2enmod cgid
service apache2 restart

Ubuntu 14.04

25 juin 2015 : Installation sans problème particulier sur Kubuntu 14.04. J'ai suivi le détail de l'install manuelle pour Debian.

Ubuntu 9.4 (version périmée)

Une version 3.64 vient d'être remontée (sponsorisée) par José-Luis Redrejo aujourd'hui vers les dépôts Debian, merci à lui. Vous pouvez suivre son statut ici : http://qa.debian.org/developer.php?login=georgesk@ofset.org#wims

Plusieurs des problèmes liés au paquet 3.62 n'y sont plus; reste à persuader quelqu'un de chez Ubuntu de remonter ça vers Ubuntu dès que ça passe dans Debian/testing (attente 10 jours + éventuels ralentissements en cas de dépendances non promues)

26 août 2009 : Installation avec le dépôt ofset : http://debian.ofset.org. Pas de problème particulier à l'installation avec apache2.

L'installation automatique des modules ne semble pas marcher ensuite. Peut-être un bogue corrigé dans la version 3.65a. Dommage que les sources ne soient pas accessibles dans le dossier src (en tout cas, je n'y suis pas arrivée).

28 mai 2009, nous avons réessayé l'installation du package wims sous le système Ubuntu 9.04 avec synaptic. Il s'agit de la version 3.62.13.1 (quand aura-t-on la version 3.64 ?)

Nous avons choisi Apache2 quand cela a été demandé.

Installation d'autre part de Povray

Comme d'habitude, ajouter une ligne de permission dans le fichier povray.conf (il est dans /etc/povray/3.6/povray.conf)

read+write* = /var/lib/wims/tmp/sessions dans le fichier

Ouvrir un navigateur et mettre comme adresse

 http://127.0.0.1/wims/

La page d'accueil apparaît et le lien de l'administration du site aussi

  WIMS gestion du site en ligne

Cliquer dessus Aller chercher le mot de passe dans le fichier indiqué.

Surprise : aucun paramètre par défaut. Des petits problèmes qu'il est inutile d'énumérer. Après des tâtonnements et la comparaison avec wims sur MacosX, on s'aperçoit que l'installation Ubuntu a créé un lien

 defaut.conf -> /etc/wims/defaut.conf

au lieu d'un lien

defaults.conf -> /etc/wims/defaults.conf

Une fois cela changé, tout va beaucoup mieux.

Création d'une classe virtuelle. Ici on retombe sur un problème réglé dans wims.3.65a (erreur interne lorsque le supervisor essaie d'entrer dans sa classe).

On revient à l'outil de maintenance. On clique sur “Modules” afin de télécharger les modules. Et cette fois-ci le téléchargement des modules se fait. Configuration de l'installation automatique. A vérifier demain.

On clique sur “Graphics” : tout va bien sauf Gnuplot (problème réglé dans wims3.65a).

Par contre, Maxima n'est pas visible par WIMS. Pour régler le problème, il faut malheureusement avoir accès aux sources. Explicitement, dans le fichier “src/wims.c” ligne 71, augmenter la valeur de rlimitdata : doubler la taille en gros est bon. Je ne sais pas si cela peut être ennuyeux de trop augmenter. En tout cas, cela est à modifier dans “l'upstream” ou à permettre de configurer dans l'interface du gestionnaire du site. A faire : vérifier les “file permissions”.

Finalement, installation de Java et de Flash utile pour la partie “client” de l'utilisation de WIMS.

Première configuration de WIMS

Suivez la page suivante : Configuration de WIMS

Vous pourriez laisser un commentaire si vous étiez connecté.
installation/ubuntu.txt · Dernière modification: 26/08/2016 23:11 par bernadette